Drupal-Sicherheitslücke mit Gefahr einer Remote Code Execution

Originalbeitrag von Branden Lynch, Threats Analyst


Im Content Management Framework Drupal wurde kürzlich eine Sicherheitslücke (CVE-2019-6340) in der Kernsoftware geschlossen. Der Fehler war als „hochkritisch“ eingestuft worden, denn Installationen sind der Gefahr von nicht autorisierter Remote Code Execution ausgesetzt. Die Lücke betrifft einen erheblichen Anteil an Drupal-Installationen, denn sie wirkt sich auf das häufig eingesetzte RESTful Web Services (rest)-Modul aus. Die folgenden Vorbedingungen sind für die Sicherheitslücke ausschlaggebend:

  1. Drupal 8.6.x, < 8.6.10 oder Drupal < 8.5.11
  2. RESTful Web Services Modul aktiviert

Nutzer sollten auf die neueste Drupal-Version aktualisieren, für die Patches vorhanden sind. Weitere technische Einzelheiten zur Schwachstelle und zum Ablauf eines möglichen Angriffs liefert der Originalbeitrag.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

*

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.